// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\w+<del.*?>.*?<\/del>(\w+)?|(\w+)?<del.*?>.*?<\/del>\w+|(\w+)?<del.*?>.*?<\/del>\w<del.*?>.*?<\/del>(\w+)").unwrap();
let string = "Tutorial<del class=\"ice-del\">Within word</del> WordEnd Tutorial<del class=\"ice-del\">Within word</del> WordEndsample<del class=\"ice-del\">total word</del>Welcome<del class=\"ice-del\">Within word</del> to RegExr v2.0 by gskinner.com!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}