using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+<del.*?>.*?<\/del>(\w+)?|(\w+)?<del.*?>.*?<\/del>\w+|(\w+)?<del.*?>.*?<\/del>\w<del.*?>.*?<\/del>(\w+)";
string input = @"Tutorial<del class=""ice-del"">Within word</del> WordEnd Tutorial<del class=""ice-del"">Within word</del> WordEndsample<del class=""ice-del"">total word</del>Welcome<del class=""ice-del"">Within word</del> to RegExr v2.0 by gskinner.com!";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}