const regex = /\w+<del.*?>.*?<\/del>(\w+)?|(\w+)?<del.*?>.*?<\/del>\w+|(\w+)?<del.*?>.*?<\/del>\w<del.*?>.*?<\/del>(\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+<del.*?>.*?<\\\/del>(\\w+)?|(\\w+)?<del.*?>.*?<\\\/del>\\w+|(\\w+)?<del.*?>.*?<\\\/del>\\w<del.*?>.*?<\\\/del>(\\w+)', 'g')
const str = `Tutorial<del class="ice-del">Within word</del> WordEnd Tutorial<del class="ice-del">Within word</del> WordEndsample<del class="ice-del">total word</del>Welcome<del class="ice-del">Within word</del> to RegExr v2.0 by gskinner.com!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}