import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+<del.*?>.*?<\\/del>(\\w+)?|(\\w+)?<del.*?>.*?<\\/del>\\w+|(\\w+)?<del.*?>.*?<\\/del>\\w<del.*?>.*?<\\/del>(\\w+)";
final String string = "Tutorial<del class=\"ice-del\">Within word</del> WordEnd Tutorial<del class=\"ice-del\">Within word</del> WordEndsample<del class=\"ice-del\">total word</del>Welcome<del class=\"ice-del\">Within word</del> to RegExr v2.0 by gskinner.com!";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}