re = /\w+<del.*?>.*?<\/del>(\w+)?|(\w+)?<del.*?>.*?<\/del>\w+|(\w+)?<del.*?>.*?<\/del>\w<del.*?>.*?<\/del>(\w+)/
str = 'Tutorial<del class="ice-del">Within word</del> WordEnd Tutorial<del class="ice-del">Within word</del> WordEndsample<del class="ice-del">total word</del>Welcome<del class="ice-del">Within word</del> to RegExr v2.0 by gskinner.com!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end