package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[a-zA-Z]{1,2}(?:\.[a-zA-Z]{1,2}){2,}\b`)
var str = `a.b.c
ab.c.dd.ee
a.b
aaa.b.cc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}