$re = '/\b[a-zA-Z]{1,2}(?:\.[a-zA-Z]{1,2}){2,}\b/m';
$str = 'a.b.c
ab.c.dd.ee
a.b
aaa.b.cc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);