const regex = new RegExp('\\b[a-zA-Z]{1,2}(?:\\.[a-zA-Z]{1,2}){2,}\\b', 'gm')
const str = `a.b.c
ab.c.dd.ee
a.b
aaa.b.cc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}