# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*,\s*(?=(?:(?:[^']*'){2})*[^']*$)/\n/g;t' <<< "1, 0, 1, 73, 0, 'root.1', 'Root Asset', '{\"site\":{\"6\":1,\"2\":1},\"core\":{\"6\":1}}'"