import re
regex = re.compile(r"\s*,\s*(?=(?:(?:[^']*'){2})*[^']*$)")
test_str = "1, 0, 1, 73, 0, 'root.1', 'Root Asset', '{\"site\":{\"6\":1,\"2\":1},\"core\":{\"6\":1}}'"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)