$re = '/\s*,\s*(?=(?:(?:[^\']*\'){2})*[^\']*$)/';
$str = '1, 0, 1, 73, 0, \'root.1\', \'Root Asset\', \'{"site":{"6":1,"2":1},"core":{"6":1}}\'';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;