using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*,\s*(?=(?:(?:[^']*'){2})*[^']*$)";
string substitution = @"\n";
string input = @"1, 0, 1, 73, 0, 'root.1', 'Root Asset', '{""site"":{""6"":1,""2"":1},""core"":{""6"":1}}'";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}