import Foundation
let pattern = #"\s*,\s*(?=(?:(?:[^']*'){2})*[^']*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1, 0, 1, 73, 0, 'root.1', 'Root Asset', '{"site":{"6":1,"2":1},"core":{"6":1}}'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)