use strict;
my $str = '1, 0, 1, 73, 0, \'root.1\', \'Root Asset\', \'{"site":{"6":1,"2":1},"core":{"6":1}}\'';
my $regex = qr/\s*,\s*(?=(?:(?:[^']*'){2})*[^']*$)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";