import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\A|\\s)@(\\w+)";
final String string = "Why is the NHL's Western Conference so dominant? by @downgoesbrown @triplec1988 http://es.pn/1cxlZUI ";
final String subst = "\\1@<a href=\"http://www.twitter.com/\\2\">\\2</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}