# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\A|\s)@(\w+)"
test_str = "Why is the NHL's Western Conference so dominant? by @downgoesbrown @triplec1988 http://es.pn/1cxlZUI "
subst = "\\1@<a href=\"http://www.twitter.com/\\2\">\\2</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.