const regex = new RegExp('(\\A|\\s)@(\\w+)', 'g')
const str = `Why is the NHL's Western Conference so dominant? by @downgoesbrown @triplec1988 http://es.pn/1cxlZUI `;
const subst = `\1@<a href="http://www.twitter.com/\2">\2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);