import Foundation
let pattern = #"(\A|\s)@(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Why is the NHL's Western Conference so dominant? by @downgoesbrown @triplec1988 http://es.pn/1cxlZUI "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1@<a href="http://www.twitter.com/\2">\2</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)