use strict;
my $str = 'Why is the NHL\'s Western Conference so dominant? by @downgoesbrown @triplec1988 http://es.pn/1cxlZUI ';
my $regex = qr/(\A|\s)@(\w+)/p;
my $subst = '\\1@<a href="http://www.twitter.com/\\2">\\2</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";