// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\A|\s)@(\w+)").unwrap();
let string = "Why is the NHL's Western Conference so dominant? by @downgoesbrown @triplec1988 http://es.pn/1cxlZUI ";
let substitution = "\\1@<a href=\"http://www.twitter.com/\\2\">\\2</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}