#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z\d@!?\-_.]{5,}$"
Local $sString = "test@test.com" & @CRLF & _
"test-test" & @CRLF & _
"test_test" & @CRLF & _
"test123" & @CRLF & _
"test!?" & @CRLF & _
"test!23" & @CRLF & _
"" & @CRLF & _
"testing" & @CRLF & _
"testin%g" & @CRLF & _
"testing%" & @CRLF & _
"%testing"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")