// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z\d@!?\-_.]{5,}$").unwrap();
let string = "test@test.com
test-test
test_test
test123
test!?
test!23
testing
testin%g
testing%
%testing";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}