import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z\\d@!?\\-_.]{5,}$";
final String string = "test@test.com\n"
+ "test-test\n"
+ "test_test\n"
+ "test123\n"
+ "test!?\n"
+ "test!23\n\n"
+ "testing\n"
+ "testin%g\n"
+ "testing%\n"
+ "%testing";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}