using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z\d@!?\-_.]{5,}$";
string input = @"test@test.com
test-test
test_test
test123
test!?
test!23
testing
testin%g
testing%
%testing";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}