$re = '/^[A-Za-z\d@!?\-_.]{5,}$/m';
$str = 'test@test.com
test-test
test_test
test123
test!?
test!23
testing
testin%g
testing%
%testing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);