import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s|\\\\n\\\\n)*(?<subject>\\S+(?:\\s[IVX]+\\.?)?)(?:\\s|\\\\n\\\\n)+(?<teacher>\\S+)(?:\\s|\\\\n\\\\n)+(?<room>\\S+)(?:\\s|\\\\n\\\\n)*";
final String string = "TSG MUM \\n\\nBS06-312\n"
+ "RQWE. FKB \\n\\nBS06-204\n"
+ "NM. JAK \\n\\nBS06-E05\n"
+ "DB. FKB \\n\\nBS06-312\n"
+ "IGT. resetk \\n\\nWender.\n"
+ "ENG I. \\n\\nWEHN BS06-E06 \\n\\nENG II \\n\\nFLEM BS06-203\n"
+ "ITSI. MUM \\n\\nBS06-E02\n"
+ "PQT. RIE \\n\\nBS11-QCR PQT \\n\\nMARK BS11-QCR \\n\\nPQT FIS \\n\\nBS11-QCR\n"
+ "INC FEY \\n\\nBS06-309\n"
+ "ABS. DOE \\n\\nBS06 ABS \\n\\nVOG BS06 \\n\\nABS HEI \\n\\nBS06 ABS \\n\\nMOR BS06 \\n\\nABS REM \\n\\nBS06 ABS \\n\\nDEI BS06 \\n\\nABS THA \\n\\nBS06\n"
+ "ENG III. \\n\\nGLIT BS06-209 \\n\\nENG II \\n\\nWANN BS06-208";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}