import Foundation
let pattern = #"(?:\s|\\n\\n)*(?<subject>\S+(?:\s[IVX]+\.?)?)(?:\s|\\n\\n)+(?<teacher>\S+)(?:\s|\\n\\n)+(?<room>\S+)(?:\s|\\n\\n)*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
TSG MUM \n\nBS06-312
RQWE. FKB \n\nBS06-204
NM. JAK \n\nBS06-E05
DB. FKB \n\nBS06-312
IGT. resetk \n\nWender.
ENG I. \n\nWEHN BS06-E06 \n\nENG II \n\nFLEM BS06-203
ITSI. MUM \n\nBS06-E02
PQT. RIE \n\nBS11-QCR PQT \n\nMARK BS11-QCR \n\nPQT FIS \n\nBS11-QCR
INC FEY \n\nBS06-309
ABS. DOE \n\nBS06 ABS \n\nVOG BS06 \n\nABS HEI \n\nBS06 ABS \n\nMOR BS06 \n\nABS REM \n\nBS06 ABS \n\nDEI BS06 \n\nABS THA \n\nBS06
ENG III. \n\nGLIT BS06-209 \n\nENG II \n\nWANN BS06-208
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)