re = /(?:\s|\\n\\n)*(?<subject>\S+(?:\s[IVX]+\.?)?)(?:\s|\\n\\n)+(?<teacher>\S+)(?:\s|\\n\\n)+(?<room>\S+)(?:\s|\\n\\n)*/
str = 'TSG MUM \\n\\nBS06-312
RQWE. FKB \\n\\nBS06-204
NM. JAK \\n\\nBS06-E05
DB. FKB \\n\\nBS06-312
IGT. resetk \\n\\nWender.
ENG I. \\n\\nWEHN BS06-E06 \\n\\nENG II \\n\\nFLEM BS06-203
ITSI. MUM \\n\\nBS06-E02
PQT. RIE \\n\\nBS11-QCR PQT \\n\\nMARK BS11-QCR \\n\\nPQT FIS \\n\\nBS11-QCR
INC FEY \\n\\nBS06-309
ABS. DOE \\n\\nBS06 ABS \\n\\nVOG BS06 \\n\\nABS HEI \\n\\nBS06 ABS \\n\\nMOR BS06 \\n\\nABS REM \\n\\nBS06 ABS \\n\\nDEI BS06 \\n\\nABS THA \\n\\nBS06
ENG III. \\n\\nGLIT BS06-209 \\n\\nENG II \\n\\nWANN BS06-208'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end