use strict;
my $str = 'TSG MUM \\n\\nBS06-312
RQWE. FKB \\n\\nBS06-204
NM. JAK \\n\\nBS06-E05
DB. FKB \\n\\nBS06-312
IGT. resetk \\n\\nWender.
ENG I. \\n\\nWEHN BS06-E06 \\n\\nENG II \\n\\nFLEM BS06-203
ITSI. MUM \\n\\nBS06-E02
PQT. RIE \\n\\nBS11-QCR PQT \\n\\nMARK BS11-QCR \\n\\nPQT FIS \\n\\nBS11-QCR
INC FEY \\n\\nBS06-309
ABS. DOE \\n\\nBS06 ABS \\n\\nVOG BS06 \\n\\nABS HEI \\n\\nBS06 ABS \\n\\nMOR BS06 \\n\\nABS REM \\n\\nBS06 ABS \\n\\nDEI BS06 \\n\\nABS THA \\n\\nBS06
ENG III. \\n\\nGLIT BS06-209 \\n\\nENG II \\n\\nWANN BS06-208';
my $regex = qr/(?:\s|\\n\\n)*(?<subject>\S+(?:\s[IVX]+\.?)?)(?:\s|\\n\\n)+(?<teacher>\S+)(?:\s|\\n\\n)+(?<room>\S+)(?:\s|\\n\\n)*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}