# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s|\\n\\n)*(?<subject>\S+(?:\s[IVX]+\.?)?)(?:\s|\\n\\n)+(?<teacher>\S+)(?:\s|\\n\\n)+(?<room>\S+)(?:\s|\\n\\n)*"
test_str = ("TSG MUM \\n\\nBS06-312\n"
"RQWE. FKB \\n\\nBS06-204\n"
"NM. JAK \\n\\nBS06-E05\n"
"DB. FKB \\n\\nBS06-312\n"
"IGT. resetk \\n\\nWender.\n"
"ENG I. \\n\\nWEHN BS06-E06 \\n\\nENG II \\n\\nFLEM BS06-203\n"
"ITSI. MUM \\n\\nBS06-E02\n"
"PQT. RIE \\n\\nBS11-QCR PQT \\n\\nMARK BS11-QCR \\n\\nPQT FIS \\n\\nBS11-QCR\n"
"INC FEY \\n\\nBS06-309\n"
"ABS. DOE \\n\\nBS06 ABS \\n\\nVOG BS06 \\n\\nABS HEI \\n\\nBS06 ABS \\n\\nMOR BS06 \\n\\nABS REM \\n\\nBS06 ABS \\n\\nDEI BS06 \\n\\nABS THA \\n\\nBS06\n"
"ENG III. \\n\\nGLIT BS06-209 \\n\\nENG II \\n\\nWANN BS06-208")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.