using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""euroPrice""> <span>(\d+\.\d+)<\/span>";
string input = @"(much text) </div> <div class=""euroPrice""> <span>1.23</span> ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}