package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div class="euroPrice"> <span>(\d+\.\d+)<\/span>`)
var str = `(much text) </div> <div class="euroPrice"> <span>1.23</span> `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}