re = /<div class="euroPrice"> <span>(\d+\.\d+)<\/span>/
str = '(much text) </div> <div class="euroPrice"> <span>1.23</span> '
# Print the match result
str.match(re) do |match|
puts match.to_s
end