// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<div class="euroPrice"> <span>(\d+\.\d+)<\/span>"#).unwrap();
let string = "(much text) </div> <div class=\"euroPrice\"> <span>1.23</span> ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}