$re = '/<div class="euroPrice"> <span>(\d+\.\d+)<\/span>/';
$str = '(much text) </div> <div class="euroPrice"> <span>1.23</span> ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);