const regex = /<div class="euroPrice"> <span>(\d+\.\d+)<\/span>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="euroPrice"> <span>(\\d+\\.\\d+)<\\\/span>', '')
const str = `(much text) </div> <div class="euroPrice"> <span>1.23</span> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}