#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(google\.com)\/(to_the_end)\/(.*[^\/])\/?$"
Local $sString = "google.com/to_the_end/" & @CRLF & _
"google.com/to_the_end/faa/fee/" & @CRLF & _
"google.com/to_the_end/faa/fee/fii"
Local $sSubst = "$1/$3/$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)