import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(google\\.com)\\/(to_the_end)\\/(.*[^\\/])\\/?$";
final String string = "google.com/to_the_end/\n"
+ "google.com/to_the_end/faa/fee/\n"
+ "google.com/to_the_end/faa/fee/fii";
final String subst = "$1/$3/$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}