using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(google\.com)\/(to_the_end)\/(.*[^\/])\/?$";
string substitution = @"$1/$3/$2";
string input = @"google.com/to_the_end/
google.com/to_the_end/faa/fee/
google.com/to_the_end/faa/fee/fii";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}