$re = '/(google\.com)\/(to_the_end)\/(.*[^\/])\/?$/m';
$str = 'google.com/to_the_end/
google.com/to_the_end/faa/fee/
google.com/to_the_end/faa/fee/fii';
$subst = "$1/$3/$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;