re = /(google\.com)\/(to_the_end)\/(.*[^\/])\/?$/m
str = 'google.com/to_the_end/
google.com/to_the_end/faa/fee/
google.com/to_the_end/faa/fee/fii'
subst = '$1/$3/$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result