use strict;
my $str = 'google.com/to_the_end/
google.com/to_the_end/faa/fee/
google.com/to_the_end/faa/fee/fii';
my $regex = qr/(google\.com)\/(to_the_end)\/(.*[^\/])\/?$/mp;
my $subst = '$1/$3/$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";