#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?<=USD|usd)\s*(\d+))|(?:\d+\s*(?=USD|usd|Usd|U.S.D))"
Local $sString = " examplestring = "This item costs 20 USD"" & @CRLF & _
" examplestring = "This item costs USD 20"" & @CRLF & _
" examplestring = "This item costs 20 U.S.D"" & @CRLF & _
" examplestring = "This item costs 20 usd"" & @CRLF & _
" examplestring = "This item costs 20 Usd"" & @CRLF & _
" examplestring = "This item costs 20USD"" & @CRLF & _
" examplestring = "This item costs usd20""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")