use strict;
my $str = ' examplestring = "This item costs 20 USD"
examplestring = "This item costs USD 20"
examplestring = "This item costs 20 U.S.D"
examplestring = "This item costs 20 usd"
examplestring = "This item costs 20 Usd"
examplestring = "This item costs 20USD"
examplestring = "This item costs usd20"';
my $regex = qr/(?:(?<=USD|usd)\s*(\d+))|(?:\d+\s*(?=USD|usd|Usd|U.S.D))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}