import Foundation
let pattern = #"(?:(?<=USD|usd)\s*(\d+))|(?:\d+\s*(?=USD|usd|Usd|U.S.D))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
examplestring = "This item costs 20 USD"
examplestring = "This item costs USD 20"
examplestring = "This item costs 20 U.S.D"
examplestring = "This item costs 20 usd"
examplestring = "This item costs 20 Usd"
examplestring = "This item costs 20USD"
examplestring = "This item costs usd20"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)