using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=USD|usd)\s*(\d+))|(?:\d+\s*(?=USD|usd|Usd|U.S.D))";
string input = @" examplestring = ""This item costs 20 USD""
examplestring = ""This item costs USD 20""
examplestring = ""This item costs 20 U.S.D""
examplestring = ""This item costs 20 usd""
examplestring = ""This item costs 20 Usd""
examplestring = ""This item costs 20USD""
examplestring = ""This item costs usd20""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}