import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=USD|usd)\\s*(\\d+))|(?:\\d+\\s*(?=USD|usd|Usd|U.S.D))";
final String string = " examplestring = \"This item costs 20 USD\"\n"
+ " examplestring = \"This item costs USD 20\"\n"
+ " examplestring = \"This item costs 20 U.S.D\"\n"
+ " examplestring = \"This item costs 20 usd\"\n"
+ " examplestring = \"This item costs 20 Usd\"\n"
+ " examplestring = \"This item costs 20USD\"\n"
+ " examplestring = \"This item costs usd20\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}