# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?<=USD|usd)\s*(\d+))|(?:\d+\s*(?=USD|usd|Usd|U.S.D))"
test_str = (" examplestring = \"This item costs 20 USD\"\n"
" examplestring = \"This item costs USD 20\"\n"
" examplestring = \"This item costs 20 U.S.D\"\n"
" examplestring = \"This item costs 20 usd\"\n"
" examplestring = \"This item costs 20 Usd\"\n"
" examplestring = \"This item costs 20USD\"\n"
" examplestring = \"This item costs usd20\"")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.