#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!.*\bThank-you$).*"
Local $sString = "//site/us/count/Pages/product-a-Thank-you" & @CRLF & _
"//site/us/count/Pages/Information-b-Thank-you" & @CRLF & _
"//site/us/count/Pages/register-c-Thank-you //site/us/count/Pages/link-d-Thank-you" & @CRLF & _
"//site/us/world/Pages/link-e-Thank-you.html //site/us/world/Pages/Register-h-Thank-you.html"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)