const regex = /^(?!.*\bThank-you$).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\bThank-you$).*', 'gm')
const str = `//site/us/count/Pages/product-a-Thank-you
//site/us/count/Pages/Information-b-Thank-you
//site/us/count/Pages/register-c-Thank-you //site/us/count/Pages/link-d-Thank-you
//site/us/world/Pages/link-e-Thank-you.html //site/us/world/Pages/Register-h-Thank-you.html`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);